Modify

Opened 6 years ago

Closed 6 years ago

#810 closed Bug (worksforme)

Paused track starts playing on volume change

Reported by: jupi Owned by: bflorat
Priority: 5, normal Milestone: 1.4.3
Component: Any (Default Component) Version: 1.4.2
Keywords: Cc:
Regression ?:

Description

If a track is paused with the "pause"-Button, playback stops, which is perfectly right. But if you then change the volume using the volume slider, the playback resumes. Additionally, the song is not shown as being played (i.e. the play/pause-Button still has the "play"-arrow).
Don't hesitate to ask for further information if required!

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by bflorat

  • Milestone changed from To Be Decided by Jajuk Team to 1.4.3
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from 1.4.3 to 1.4.2

Issue reproduced. We also found related issues by reading the code. Among them: position should be disabled when paused. Information panel forget to subscribe to pause and resume events.

On this issue itself: the main problem comes from mplayer itself : in slave mode, any command resume the playback, even a volume change. The only possible fix was to disable the volume slider from jajuk, what we did.

Please check 1.4.3 RC4 (on http://repository.jajuk.info/jajuk/testing/maintenance/ ) and provide feedback.

comment:2 Changed 6 years ago by jupi

  • Resolution fixed deleted
  • Status changed from closed to reopened

Ok, fix works, volume slider is disabled on track pause or stop and re-enabled on play. But another bug has been introduced by this fix: let's assume the playlist is empty, playback is stopped. The volume slider is disabled. If you now refill the playlist by dragging an album onto it, playback starts automatically and is indicated by the changing play/pause-icon in jajuks bottom, but the volume slider is not re-enabled. You have to pause and then resume the playback using the buttons in jajuks bottom to get the volume control enabled.

comment:3 Changed 6 years ago by bflorat

Ticket cleanup request. I cannot reproduce the problem described on album drag/drop on volume slider against jajuk 1.4.4 (the volume slider is not disabled after a stop playback). Do you confirm this issue ?

comment:4 Changed 6 years ago by bflorat

  • Resolution set to worksforme
  • Status changed from reopened to closed

Cannot reproduce, closed. Feel free to reopen if required.

Add Comment

Modify Ticket

Change Properties
Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.