Modify

Opened 2 years ago

Closed 2 years ago

Last modified 21 months ago

#1825 closed Bug (fixed)

OSX 10.7 - UI doesn't work after minimize/maximize

Reported by: info@… Owned by: bflorat
Priority: 9, highest Milestone: 1.10 "Gute Laune"
Component: User Interface Version: 1.9.6
Keywords: Cc:
Regression ?:

Description

Starting Jajuk. If I minimize Jajuk and then put it again to front I'm not be able to select anything. Ui seems to be freezed (but if I double click somewhere, for example a song, jajuk start to play).
I have to make full screen (and some time mouse cursor desapperars) and back to window mode, and then jajuk works normally.

See video attached.

Attachments (1)

jajuk.mp4 (756.8 KB) - added by info@… 2 years ago.
Screen capture video

Download all attachments as: .zip

Change History (14)

Changed 2 years ago by info@…

Screen capture video

comment:1 Changed 2 years ago by bflorat

  • Milestone changed from To Be Qualified by Jajuk Team to To Be Decided by Jajuk Team
  • Priority changed from 5, normal to 9, highest

Thanks for reporting.

I can't reproduce under OSX 10.5.8, seems that JRE behavior is different.

Which JRE version do you run ? did you applied the last JRE update for Lion ? [1]

[1] http://support.apple.com/kb/DL1421

Thanks

comment:2 Changed 2 years ago by info@…

Which JRE version do you run ? did you applied the last JRE update for Lion ?

YES. I've tried to re-download and re-install. Same results.

My system: Mac OS X Lion 10.7.3 (11D50)

comment:3 Changed 2 years ago by bflorat

We made a blind fix in the 1.9.7 daily build [1], could you please have a try ?

[1] http://integration.jajuk.info/jenkins/job/maintenance/

comment:4 Changed 2 years ago by info@…

Downloaded and installed 1.9.7 build. Same problem..

comment:5 Changed 2 years ago by bflorat

Ok, thanks anyway.

We have now to find a Lion in order to reproduce then fix this issue. We will update this ticket when done.

comment:6 Changed 2 years ago by bflorat

  • Milestone To Be Decided by Jajuk Team deleted
  • Type changed from Bug to To be reproduced

I can't reproduce under Lion neither [1]. Sorry but we can't go further until we reproduce this. It may be a problem specific to your installation ? I move this into "To be reproduced" section.

Any others reports are welcomed so we know if it is a broadly affecting issue or only very specific.

[1] 1OSX 0.7.3, JRE 1.6.0_26-b03-383-11D50

comment:7 Changed 2 years ago by info@…

Some memory management issue? I have 8GB Ram installed. The only thing I can do is to let you see my Mac directly, through Teamviewer App.

comment:8 Changed 2 years ago by bflorat

Why not, thanks for the proposition but it would be also require you (or me) to install on your OSX eclipse to debug directly on your box. Would it be possible ?

I don't think it's related with memory.

comment:9 Changed 2 years ago by info@…

Let me know the link to download the correct IDE.

comment:11 Changed 2 years ago by bflorat

  • Milestone set to 1.9.7
  • Type changed from To be reproduced to Bug

Should be fixed under Lion in Build #1195 [1]. We still have to check for regressions under Leopard.

[1] http://integration.jajuk.info/jenkins/job/maintenance/1195/

comment:12 Changed 2 years ago by bflorat

  • Resolution set to fixed
  • Status changed from new to closed

All right, no regressions observed under Leopard neither. I close this ticket.

fix backported into develop branch.

comment:13 Changed 21 months ago by bflorat

  • Milestone changed from 1.9.7 to 1.10 "Gute Laune"

Add Comment

Modify Ticket

Change Properties
Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.