Modify

Opened 4 years ago

Closed 4 years ago

#1617 closed Task (duplicate)

Various issues with Song Rating system

Reported by: mats.ahlgren@… Owned by:
Priority: 5, normal Milestone: To Be Decided by Jajuk Team
Component: Functional Version: 1.9RC3
Keywords: rating Cc:
Regression ?:

Description (last modified by bflorat)

There are various issues with the current Song Rating system, and there were too many to put in separate tickets. I am filing this under a single ticket of type="discussion".

  • there is a very large amount of discreteness between 3stars and 4stars; sometimes, adjusting the happyface-rating of a song causes the song to increase or decrease by 2 or more stars
  • I do not ever use an unhappyface below the "neutral" rating because I would just ban the track
  • Pardon/GreenCheckmark? doesn't seem to have any useful function
  • Almost all music in my collection is rating 3-4 stars; this tells me almost nothing. I'd much prefer if my music was rated 1-4 stars (1=okay, 2=great, 3=amazing, 4=very amazing) and unliked tracks were simply Banned.
  • it is impossible to "fix" an accidentally-skipped song
  • users should have the option of saying "Do not automatically try to guess my preferences, but always use the rating I tell you:"
    • no preference, or worse -> 1star
    • like -> 2star
    • like a lot -> 3star
    • love -> 4star
  • there is no way to skip a song early without affecting its rating -- thus is relevant if, say, a song is not playing properly (e.g. if everyone other song is playing silently due to a bug), or perhaps if one is simply if someone requested a different song

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by mats.ahlgren@…

One of the main issues, is that I cannot skip a song (e.g. if I want to stop listening to music right now, if I want to quickly go through songs, etc.) without changing its rating.

There needs to be some way (e.g. keyboard shortcut) to temporarily disable changes to ratings -- or the system ought to not take song-listened-duration into account.

comment:2 Changed 4 years ago by bflorat

  • Component changed from (Jajuk Members) Any (Default Component) to (Java Developer) Functional
  • Keywords rating added
  • Priority changed from 1, lowest to 5, normal
  • Version set to 1.9RC3

To be discussed in Gute Laune.

comment:3 Changed 4 years ago by mats.ahlgren@…

Another example for the sake of discussion (just one of the many issues):

I just double-clicked the Heart/Favorites/Loved? auto-playlist, and the first song stuttered (stopped playing and began playing again) due to an engine glitch. This resulting in the song losing so much rating (~600% of the standard deviation of the playlist? 99score to <96score?) that it went off the playlist.

(Granted there ought to be more resilient and infinite-length Smart Playlists like DJs, and the engine glitch should not have occurred...)

comment:4 Changed 4 years ago by bflorat

  • Description modified (diff)

comment:5 Changed 4 years ago by bflorat

  • Type changed from Discussion to Task

Globally, the described behavior is expected :

  • It is true that in a new collection, rates are often either very low or high but this should improve with time. However, we may adjust the current formula [1], by instance by using a 50% factor to nb of plays equals to the play time factor which is perhaps overestimated indeed. Or we could use a logarithm to the playtime part like we already do with the nb of plays. Any other suggestion is welcomed.
  • It seems a good idea to add an option to allow direct rating (only preferences)
  • Ban/pardon (green check mark) works as expected

An important point to consider is the ability to re-compute every rates after a jajuk upgrade. At a first glance, it doesn't seem to be a problem.

[1] http://jajuk.info/index.php/Jajuk_rating_system#More_details_on_rating_computation

comment:6 Changed 4 years ago by bflorat

  • Resolution set to duplicate
  • Status changed from new to closed

For manual rating, see #1758, nothing left on this ticket apparently -> closing

Add Comment

Modify Ticket

Change Properties
Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.