Modify

Opened 4 years ago

Closed 4 years ago

#1610 closed Bug (duplicate)

Total data loss / corruption of all preferences

Reported by: mats.ahlgren@… Owned by:
Priority: 10, highest Milestone: To Be Decided by Jajuk Team
Component: Any (Default Component) Version: 1.8.4
Keywords: Cc:
Regression ?:

Description

My X-server crashed, presumably taking Jajuk down with it. However when I reopened Jajuk, the theme was different, and I got the "the last instance will save preferences" dialog. I select one of the options, but force-kill the app. I then look in .jajuk/conf.properties, and it seems to be the *default*.

Moreover, there are no conf.properties backups (like the collection.xml file; however the collection database was fine).

Setting severity to max.

It seems as if Jajuk should keep backups of the preferences, and not override the preferences if it detects corruption. If corruption is detected, it should:

1) make a temporary backup of the current conf

2) prompt the user: Please quit, or force-quit, any other instances of Jajuk that are running. [Ok] -- no other options

3) Say "Jajuk was not shut down cleanly. Reverting to last clean preference backup from [datetime]. Other corrupt preference files have been marked in ~/.jajuk and saved for you."

Logs reveal nothing interesting about how this could have happened. Dumb spam filter is preventing me from uploading log or inserting a URL to pastebin, but I can copy-paste into a comment if desired.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by mats.ahlgren@…

  • Resolution set to duplicate
  • Status changed from new to closed

Trac triple-posted... marking as duplicate of #1611

Add Comment

Modify Ticket

Change Properties
Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.