Modify

Opened 5 years ago

Closed 5 years ago

#1606 closed Bug (fixed)

NPE on Windows when refreshing device

Reported by: centic Owned by: centic
Priority: 7, high Milestone: 1.9 "Killer Queen"
Component: Functional Version: 1.9-dev
Keywords: Cc:
Regression ?:

Description

reporting this as ticket as I don't have a dev environment on this machine. I was testing with the latest version from http://integration.jajuk.info/hudson/job/Jajuk%20Daily%20Build%20-%20Trunk/lastSuccessfulBuild/artifact/

I was testing on Windows and tried to refresh my collection, but got the following:

2010/04/29 22:02:28 [ERROR] null / null [AWT-EventQueue-0] (PerspectiveManager?.java:180)
java.lang.NullPointerException?

at org.jajuk.base.Directory.getDirectories(Directory.java:154)
at org.jajuk.ui.views.FilesTreeView?.populateFromDirectory(FilesTreeView?.java:966)
at org.jajuk.ui.views.DeviceNode?.loadChildren(FilesTreeView?.java:1066)
at org.jajuk.ui.helpers.LazyLoadingTreeExpander?.treeWillExpand(LazyLoadingTreeExpander?.java:52)
at javax.swing.JTree.fireTreeWillExpand(Unknown Source)
at javax.swing.JTree.setExpandedState(Unknown Source)
at javax.swing.JTree.expandPath(Unknown Source)
at javax.swing.JTree.expandRow(Unknown Source)
at org.jajuk.ui.views.FilesTreeView?.expand(FilesTreeView?.java:492)
at org.jajuk.ui.views.FilesTreeView?.initUI(FilesTreeView?.java:324)
at org.jajuk.ui.perspectives.PerspectiveManager?$1.run(PerspectiveManager?.java:178)
at java.awt.event.InvocationEvent?.dispatch(Unknown Source)

full logfile attached

Attachments (1)

jajuk.log (86.1 KB) - added by centic 5 years ago.
logfile

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by centic

logfile

comment:1 Changed 5 years ago by centic

this was with a device that I had created back in autumn 2009, I did not use Jajuk on this machine since then. Creating a new device worked fine.

comment:2 Changed 5 years ago by bflorat

  • Owner set to centic

I don't see any possible reason how directory.getFio().getParentFile() could throw an NPE. Maybe your device was created using an old 1.9 dev version ? in this case, your collection was maybe corrupted (I remember I fixed a couple of issues similar to this one in early 1.9)...

We may need the original collection file to check it.

I leave you this ticket as I cannot reproduce

comment:3 Changed 5 years ago by anonymous

  • Resolution set to fixed
  • Status changed from new to closed

Yes, it may have been a collection which I created using a dev-version. I added sanity checks to the code at that point.

Add Comment

Modify Ticket

Change Properties
Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.