Modify

Opened 5 years ago

Closed 5 years ago

#1590 closed Bug (fixed)

Error when changing both file name and associated track

Reported by: Markus.Lindenmann@… Owned by:
Priority: 5, normal Milestone: 1.9 "Killer Queen"
Component: Functional Version: 1.9RC1
Keywords: ID3 Tag organize file Cc:
Regression ?:

Description

When changing the name and a tag information in the properties windows, guess what will be done first ... right, the file name ... Think about it :) --> you will get an error, when jajuk tries to change the tag information on the old filename/path ;)

Secondly: Album-Artist Informations seems to be tagged in an incorrect/lossy way ... When i have a look in ID3 Tag Editor, no changes where done sometimes ... as a reason the "Organize Files" Function is moving everything to "Unknown" ...

And last but not least, the "Organize Files" Functions is sometimes freezing - a jajuk restart helps ... (there is no action in the bottom-left status bar and the cursor shows the "busy" icon ...) but still playing mp3s

None the less: Nice Work so far!

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by bflorat

  • Priority changed from 6, normal to 5, normal
  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from Two Bugs in Track/File Properties to Error when changing both file name and associated track

When changing the name and a tag information in the properties windows, guess what will be done first ... right, the file name ... Think about it :) --> you will get an error, when jajuk tries to change the tag information on the old filename/path ;)

All right, fixed in trunk, will be available in 1.9 RC3. This was a very old issue.

Secondly: Album-Artist Informations seems to be tagged in an incorrect/lossy way ... When i have a look in ID3 Tag Editor, no changes where done sometimes ... as a reason the "Organize Files" Function is moving everything to "Unknown" ...

Please create a new ticket and provide more information like a sample file

And last but not least, the "Organize Files" Functions is sometimes freezing - a jajuk restart helps ... (there is no action in the bottom-left status bar and the cursor shows the "busy" icon ...) but still playing mp3s

Please create a new ticket if you can reproduce and please provide any log (Help-> Show debug trace). You can also launch during the freeze the 'jstack -l <jajuk pid>' command , and send us the result.
@team : cannot reproduce and I don't see how it could happen as the the organize action (RefactoringAction?) is executed in a dedicated thread, not the EDT.

Add Comment

Modify Ticket

Change Properties
Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.