Modify

Opened 5 years ago

Closed 4 years ago

#1588 closed Bug (worksforme)

Windows special folder issue

Reported by: bob_514450@… Owned by: bflorat
Priority: 6, normal Milestone: 1.9 "Killer Queen"
Component: Core Version: 1.8.4
Keywords: Cc:
Regression ?:

Description

A sub-folder exist in a device (wich is a directory), but I can't see it even if I refresh the content. I tried to create a device directly with the folder, but the Java Explorer doesn't find it. I'm sure it exists, I see it in Windows Explorer.

Thank you!

Attachments (2)

bug jajuk1.JPG (167.4 KB) - added by bob_514450@… 5 years ago.
bug jajuk2.JPG (197.1 KB) - added by bob_514450@… 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by bob_514450@…

Changed 5 years ago by bob_514450@…

comment:1 Changed 5 years ago by bob_514450@…

I had screenshots.

The playlists in the folder (Music de Martin) and sub-folders are available in the Playlists list in Jajuk, but the folder itself is invisible.

Thank you!

comment:2 Changed 5 years ago by bflorat

Can't reproduce (at least under Linux). Please:

  • Provide the exact OS you use (Windows XP ?)
  • Any particularity of this directory (seems that it is seen as music by windows)
  • Check that tout device has been properly refreshed. To make sure, please select your device in files tree view -> right click -> Force refresh -> fast refresh.

Note as well that newer jajuk versions are available : 1.8.4 for stable and 1.9RC2 for unstable.

comment:3 Changed 5 years ago by bob_514450@…

  • Version changed from 1.8.2 to 1.8.4

The folder was a "My music" folder from a computer with Vista. I'm using XP Pro SP3. I installed Jajuk 1.8.4 and force refreshing many times. The folder stay invisible in any view, but the playlists inside the folder appear in the playlists list.

This is the structure of the folder: Music de Martin/folders for artists/folders for albums/mp3s, playlists, cover image...

I forced the type so Windows sees it has music.

Thank you

comment:4 Changed 5 years ago by bflorat

  • Component changed from (Jajuk Members) Any (Default Component) to (Java Developer) Core
  • Milestone changed from To Be Decided by Jajuk Team to 1.9 "Killer Queen"
  • Owner set to bflorat
  • Type changed from Discussion to Bug

Maybe related with windows special directories, see #988 , to be deepen.

comment:5 Changed 5 years ago by bob_514450@…

  • Resolution set to fixed
  • Status changed from new to closed

I solve the problem: I copied all the files (without the desktop.ini and all the other hidden files) to a new folder.

comment:6 Changed 5 years ago by bflorat

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from Unable to find a folder to Windows special folder issue

OK, thanks for the feedback. We'll check if a better solution can be found in upcoming 1.9 but I'm not very optimistic.

comment:7 Changed 4 years ago by bflorat

  • Resolution set to worksforme
  • Status changed from reopened to closed

I cannot reproduce here (under WXP SP3 in my My Music special directory). My music loads fine. Maybe the desktop.ini file from Vista was not backward compatible into WXP or something.

I close this ticket, assuming it is a non standard case.

Add Comment

Modify Ticket

Change Properties
Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.